Driver App Login issue

    Audience Drivers
    Applies To Motive Driver App

     

    Symptoms: Driver App Login issue

    • I’m unable to Login my Driver App account.
    • My Driver App shows an error on the Login screen. 

     

    Cause

    • Outdated version of Driver App 
    • Incorrect Username or Password
    • Unstable or no internet connection
    • Using the Motive Fleet App instead of the Motive Driver App

     

    Solution

    1. Restart the mobile device (power it off and then power it on). 
    2. Confirm your connectivity with a stable internet connection
    3. Open the Play Store/App Store to ensure your Driver App is updated
    4. Login to your Driver App and make sure to use the correct Username and Password
    Note: If the issue continues, please share a screenshot or a small video of the App behavior and email it to support@gomotive.com to get it resolved.

     

    Related Content

    Was this article helpful?
    9 out of 11 found this helpful

    Share this with others