ELD Malfunctions/DD Codes

    Audience  Drivers 
    Applies To  Driver App 

     

    Symptom(s): ELD Malfunctions/ DD Codes

    • Red, orange, or yellow dot displays in the diagnostics field in Driver App.
    • Codes with numbers like Code 1, Code 2, Code 3, Code 4, Code 5 and Code 6 display in the diagnostic field.
    • Codes with alphabets like Code P, Code E, Code L, Code T, Code R, Code S, and Code O display in the diagnostic field.
    Note: These codes can appear on the vehicle gateway or within the app, indicating a problem with either the vehicle or the app.

     

    Cause

    Data Diagnostic (DD) Codes

    1. Data Diagnostic codes (codes with numbers) represent the short-term issues– the minor issues that can come up on a Vehicle Gateway.

    2. The causes for specific Data Diagnostic codes include:

    • Code 1: Vehicle Gateway does not power up within 1 minute of the engine turning on.
    • Code 2: Vehicle Gateway loses connection with the engine while idling for more than 60 seconds (CAN)/ > 5 seconds (US) on the following elements: GPS, VIN, date/time, engine hours.
    • Code 3: Missing data elements in an ELD event (missing lat/lon, missing vehicle kilometers, missing engine hours data, etc)
    • Code 4: Internal monitoring of the data transfer test fails and is unable to send the output file data
    • Code 5: Unidentified drive time for more than 30 min for the vehicle over the last 24 hr period.

     

    Malfunction Codes

    1. Malfunction codes (codes with alphabets) represent long-term issues. These issues are more significant issues that require attention.
    2. The causes for specific Malfunction codes include:

    • Code P: Vehicle Gateway is unplugged, and there is a driving time of more than 30 minutes over 24hr period across all driver profiles, including the unidentified driver profile.
    • Code E: Vehicle Gateway loses connection for a cumulative for more than 30 minutes of missing data elements: GPS, VIN, date/time, engine hours.
    • Code L: Vehicle Gateway cannot obtain a valid GPS position within 5 miles of the last valid position for more than 60 minutes of driving over 24-hour period.
    • Code T: Vehicle Gateway’s time varies more than 10 minutes from UTC time.
    • Code R: Vehicle Gateway’s storage space is exceeded and can no longer record new event data.
    • Code S: Internal monitoring of the data transfer test fails and is unable to send the output file data

     

    Solution

    • Contact Support to resolve both ELD malfunctions or DD codes.
    Note: Short-term issues are usually resolved by the driver following the steps indicated in the code. For long-term issues, drivers may need to take their vehicle to a repair shop or contact a mechanic to resolve the issue. In some cases, the issue may be with the app, and the driver may need to update or reinstall it.

     

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