Unable to Update the Motive Driver App (Android)

Symptoms

  • You are trying to update the Motive Driver App on your Android phone but are unable to do so.

Possible Causes

  • Cache and data buildup on your mobile device may prevent the app from updating.
  • Your device is not supported or is running an incompatible OS version.

Solution

If you are unable to update the Motive Driver App, follow these troubleshooting steps:

  • Confirm that your mobile device is supported and running on a compatible OS version for the Motive App. Refer to the article: [What are the recommended devices for Motive products?]
  • Make sure you have a stable and strong internet connection (Wi-Fi or mobile data).
  • Open your mobile device’s Settings app.

216.jpg

  • Tap on Apps & notifications to see all apps.

218.jpg217.jpg

Note: This option in device settings may vary based on the mobile device make and model but you will always have the option where all the downloaded apps can be seen listed.
  • Scroll down and tap on Google Play Store.

219.jpg

  • Tap on Storage which will lead you to a page where you would find the options for clearing cache and data.

220.jpg

  • Tap on clear cache and later on clear data.

222.jpg221.jpg

  • Once done, restart the Google Play Store and try updating the Motive Driver App again.

223.jpg

  • If you still can’t update the app after clearing cache & data, restart your mobile device and attempt the update again.
Was this article helpful?

Share this with others