Vehicle Gateway Not Recording Drive Time

    Audience Drivers, Fleet Admins
    Applies To Vehicle Gateway

     

    Description:

    This SOP is to be followed when customers using the Motive Vehicle Gateway report that their VG is not recording the vehicle’s drive time. This process should help identify the most probable cause of the vehicle gateway not recording drive time and determine the correct resolution to provide.

    Symptoms:

    • Drive Time comes up as 0 for trips
    • Driver App does not put Driver into drive mode when the vehicle moves past 5 MPH
    • Location history missing

    Cause:

    • Cable Issue: Incorrect Cabe Installation
    • Corrosion/Damaged Pins: On the vehicle's diagnostic port, On the cable connector, On the Vehicle Gateway port
    • Vehicle Issue: Open fault codes, Data not being provided from the vehicle's ECM/ECU
    • Vehicle Gateway Issue: Vehicle Gateway firmware is not updated

    Solution:

    Confirm the Status of the LED lights on the Vehicle Gateway:

    • Left LED Green: Indicates the VG has a GPS signal.
    • Left LED Red: Indicates the VG does not have a GPS signal.
    • Right LED Solid Green: Indicates the driver app is connected.
      Note: This status does not indicate whether or not the VG is capturing vehicle telematics. To confirm this with the LEDs, the Motive App must be disconnected from the VG.
    • Right, LED Solid Red: Indicates the VG is not capturing vehicle telematics, and the driver app is not connected.
    • Right LED Slow Blinking Red: Indicates the VG is capturing engine speed and the driver app is not connected.
    • Right LED Fast Blinking Red: Indicates the VG is capturing engine speed telematics, the vehicle is in motion and the driver app is not connected.

    Troubleshooting steps:

    Note: Ensure the cables are correctly installed & securely connected. Check and fix any fault codes that are open (related to your speed sensors).
    1. Open your Driver App on your mobile device and ensure it says No Vehicle on the top right.
    2. Turn the engine off & take the keys out.
    3. Unplug the cable from the vehicle's diagnostic port & the Vehicle Gateway unit.
    4. Check the following ports for corrosion/damage/missing pins.
            ‣ Both ends of the Motive cable connector
            ‣ Vehicle diagnostic port pins and ensure that the pins are not pushed back
            ‣ Vehicle Gateway device's connector port (NOT USB PORT)
    5. Take pictures of both ends of the Motive cable, the Vehicle Gateway device's port, and the diagnostic port/ fuse box (if the fuse box connector is in use).
    6. Once the lights on the unit turn off, leave it unplugged for 5 minutes.
    7. Plug the cable back into the unit and the diagnostic port/ fuse box, and turn on the engine. If the
    8. right LED starts blinking, the Vehicle Gateway is communicating with the ECM.
    9. Connect to the Vehicle Gateway and do a test drive to see if it records.
    Note: If it still doesn't work, please contact our 24/7 Support Helpline.

     

    Related Content:

    Was this article helpful?

    Share this with others